LAOX ニュース
en ja zh

パッケージを pubspec.yaml へ追記する手順

Flutter

Flutter 開発で pubspec.yaml に webview_flutter を追加したい場合、以下のように記述します。

webview_flutter 0.3.24 以上を使用したい場合の例

dependencies:    
  flutter:    
    sdk: flutter    

webview_flutter: ^0.3.24    

pubspec.yaml はインデントが重要な意味を持ちます。
webview_flutter: ^0.3.24 の記述は、インデントしてはいけません。
dependencies: と同様にインデントなしで記述してください。

pubspec.yaml を定義し終えたら pubspec.yamlの存在するディレクトリを開き以下のコマンドを実行します。

$ flutter pub get    
Running "flutter pub get" in webview_flutter...                     0.4s    

となれば正常です。これでdartコード上で下記インポートが有効化されます。

import 'package:webview_flutter/webview_flutter.dart';    
Dart

おすすめの記事